Data Processing Delays

Incident Report for Molequle

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 23:30 CEST

Monitoring

A fix has been implemented and we are monitoring the results. We'll keep this incident open until all the backlog has been processed.
Posted Aug 26, 2026 - 20:43 CEST

Identified

We have identified the issue and are working on a fix.
Posted Aug 26, 2026 - 15:41 CEST

Investigating

Our data processing infrastructure is experiencing some delays at the moment. We are currently investigating the issue.
Posted Aug 26, 2026 - 10:35 CEST
This incident affected: Molequle Platform (API, Data Pipeline, Data Unification).