Molequle applications are unreachable

Incident Report for Molequle

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 16:05 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 30, 2025 - 15:36 CEST

Identified

We have identified an issue with some SSL certificates and are currently working on resolving the issue.
Posted Sep 30, 2025 - 15:04 CEST

Investigating

We are seeing elevated error rates and are currently investigating an issue with all Molequle applications.
Posted Sep 30, 2025 - 14:03 CEST
This incident affected: Molequle Applications (Sales Intelligence) and Molequle Platform (API).