Molequle platform issue

Incident Report for Molequle

Resolved

This incident has been resolved.
Posted Oct 24, 2023 - 17:31 CEST

Monitoring

A temporary fix has been implemented. We keep monitoring this issue while we investigate the root cause .
Posted Oct 24, 2023 - 16:44 CEST

Investigating

We are currently investigating an issue which is impacting the availability of the Molequle API and all extensions.
Posted Oct 24, 2023 - 16:17 CEST
This incident affected: Molequle Applications (Sales Intelligence) and Molequle Platform (API).