Molequle Actions

Incident Report for Molequle

Postmortem

On Friday, October 18, 2024, at around 4:30 PM CEST, some customers reported issues with Molequle, where specific actions failed to execute correctly.

Timeline

  • 4:30 PM CEST: The issue was reported by some customers, specifiying that Molequle actions were failing to run.
  • 6:15 PM CEST: An initial investigation revealed a misconfiguration in the record-filtering mechanism. A temporary fix was deployed, which resolved the issue for some customers.
  • Monday, October 21, 2024 at 9:30 am: We’ve monitored the situation over the weekend and a permanent fix was deployed.

Root Cause Analysis

The issue was caused by a misconfiguration in the underlying filtering logic within Molequle, which led to an error during record selection for certain Molequle actions. This configuration issue impacted the application’s ability to trigger smart campaigns within Marketo.

Preventative Measures

We’ve already implemented additional automated tests to detect similar filtering issues in early stages.

Posted Oct 30, 2024 - 12:56 CET

Resolved

We've received reports from some customers that Molequle actions didn't run in some cases and resulted in an error.
Posted Oct 18, 2024 - 16:30 CEST