Sales Intelligence Inaccessible

Incident Report for Molequle

Resolved

We are no longer seeing any errors in our logs, and all previously affected Molequle instances are back up and running.
Posted Jul 03, 2025 - 09:41 CEST

Monitoring

A fix was deployed earlier. We are actively monitoring the issue and investigating the root cause of the blocked requests.
Posted Jul 03, 2025 - 09:30 CEST

Update

We have identified the root cause of the issue and are currently in the process of restoring the affected instances. A recent change to some services in our production environment is causing certain requests to be blocked.
Posted Jul 03, 2025 - 09:22 CEST

Investigating

Some customers are currently experiencing issues accessing the Sales Intelligence application. We are investigating the cause of these issues.
Posted Jul 03, 2025 - 08:05 CEST
This incident affected: Molequle Applications (Sales Intelligence).