Delays in loading application

Incident Report for Molequle

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 16:58 CEST

Monitoring

We've deployed a fix and are now monitoring the system to make sure everything is working as expected.
Posted Sep 04, 2025 - 16:21 CEST

Identified

We have identified an issue with our queue service and have already deployed a fix.
Posted Sep 04, 2025 - 16:19 CEST

Investigating

We are currently investigating delays and issues with loading the application, and our team is working to restore normal performance.
Posted Sep 04, 2025 - 15:30 CEST
This incident affected: Molequle Applications (Sales Intelligence) and Molequle Platform (API).